Fix line over 80 characters of if-condition part and also indent the lines to tell the difference between the condition and body of the if statement. Then I think we can keep the readability and meet coding style with this change. Signed-off-by: Masaru Nomura <massa.nomura@xxxxxxxxx> --- drivers/staging/dgnc/dgnc_neo.c | 8 +++++--- 1 file changed, 5 insertions(+), 3 deletions(-) diff --git a/drivers/staging/dgnc/dgnc_neo.c b/drivers/staging/dgnc/dgnc_neo.c index 8988346..c211f9f 100644 --- a/drivers/staging/dgnc/dgnc_neo.c +++ b/drivers/staging/dgnc/dgnc_neo.c @@ -838,9 +838,11 @@ static void neo_param(struct tty_struct *tty) * Have the UART interrupt on modem signal changes ONLY when * we are in hardware flow control mode, or CLOCAL/FORCEDCD is not set. */ - if ((ch->ch_digi.digi_flags & CTSPACE) || (ch->ch_digi.digi_flags & RTSPACE) || - (ch->ch_c_cflag & CRTSCTS) || !(ch->ch_digi.digi_flags & DIGI_FORCEDCD) || - !(ch->ch_c_cflag & CLOCAL)) { + if ((ch->ch_digi.digi_flags & CTSPACE) + || (ch->ch_digi.digi_flags & RTSPACE) + || (ch->ch_c_cflag & CRTSCTS) + || !(ch->ch_digi.digi_flags & DIGI_FORCEDCD) + || !(ch->ch_c_cflag & CLOCAL)) { ier |= UART_IER_MSI; } else { ier &= ~UART_IER_MSI; -- 1.7.9.5 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel