On Fri, 2014-04-04 at 18:17 +0300, Kumar Amit Mehta wrote: > What Walter mentioned also makes sense, So shouldn't it be something > like this: I'm not Dan, but: > [amit@localhost linux-next]$ git diff > diff --git a/drivers/staging/comedi/drivers/pcl812.c > b/drivers/staging/comedi/drivers/pcl812.c > index 160eac8..552b696 100644 > --- a/drivers/staging/comedi/drivers/pcl812.c > +++ b/drivers/staging/comedi/drivers/pcl812.c > @@ -803,16 +803,14 @@ static int pcl812_ai_cmd(struct comedi_device > *dev, struct comedi_subdevice *s) > > pcl812_ai_set_chan_range(dev, cmd->chanlist[0], 1); > > + devpriv->ai_dma = 0; > if (devpriv->dma) { /* check if we can use DMA transfer */ > devpriv->ai_dma = 1; > for (i = 1; i < cmd->chanlist_len; i++) > if (cmd->chanlist[0] != cmd->chanlist[i]) { > /* we cann't use DMA :-( */ > - devpriv->ai_dma = 0; No. You enable unwanted DMA capability here. There's a typo of can't too. > break; > } > - } else > - devpriv->ai_dma = 0; Otherwise, I suppose either style is OK. _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel