These patches are fine and they were applied already. On Wed, Mar 12, 2014 at 12:50:55PM -0400, Mark Hounschell wrote: > @@ -4368,15 +4364,16 @@ static void dgap_do_bios_load(struct board_t *brd, uchar __user *ubios, int len) > /* > * Checks to see if the BIOS completed running on the card. > */ > -static void dgap_do_wait_for_bios(struct board_t *brd) > +static int dgap_do_wait_for_bios(struct board_t *brd) I wish this funciton returned negative error codes on error. It is poorly named for a boolean function. > { > uchar *addr; > u16 word; > u16 err1; > u16 err2; > + int ret = 0; The ret variable is not needed. Replace it with zero literal for better readability. > @@ -4455,15 +4452,16 @@ static void dgap_do_fep_load(struct board_t *brd, uchar *ufep, int len) > /* > * Waits for the FEP to report thats its ready for us to use. > */ > -static void dgap_do_wait_for_fep(struct board_t *brd) > +static int dgap_do_wait_for_fep(struct board_t *brd) Same as dgap_do_wait_for_bios(). regards, dan carpenter _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel