On Tuesday, March 11, 2014 10:49 AM, Joe Perches wrote: > On Tue, 2014-03-11 at 17:42 +0000, Hartley Sweeten wrote: >> On Tuesday, March 11, 2014 10:33 AM, Fred Akers wrote: >>> This patch fixes a few function names that are very long and are >>> not in the correct naming style > [] >>> diff --git a/drivers/staging/comedi/drivers/addi-data/hwdrv_apci035.c b/drivers/staging/comedi/drivers/addi-data/hwdrv_apci035.c > [] >>> @@ -111,7 +111,7 @@ static int i_Temp; >>> static int i_Flag = 1; >>> /* >>> +----------------------------------------------------------------------------+ >>> -| Function Name : int i_APCI035_ConfigTimerWatchdog | >>> +| Function Name : int apci035_timer_config | >>> | (struct comedi_device *dev,struct comedi_subdevice *s, | >>> | struct comedi_insn *insn,unsigned int *data) | >>> +----------------------------------------------------------------------------+ >> >> Nitpick... These obvious function comment blocks should be removed. >> That should be a separate patch. Maybe a patch 1/2 before this one so >> you don't have to update the comments. > > Maybe convert them to kernel-doc style? > > /** > * foobar() - short function description of foobar > * @arg1: Describe the first argument to foobar. > * @arg2: Describe the second argument to foobar. > * One can provide multiple line descriptions > * for arguments. For exported functions I agree, but the (dev, s, insn, data) is athe standard parameter list for most of the comedi subdevice callbacks. I don't think these need any comments. Regards, Hartley _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel