Re: [PATCH] Staging: olpc_dcon: replace some magic numbers

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sat, Aug 03, 2013 at 10:44:35PM +0200, Jens Frederich wrote:
> @@ -126,7 +127,7 @@ static int dcon_bus_stabilize(struct dcon_priv *dcon, int is_powered_down)
>  power_up:
>  	if (is_powered_down) {
>  		x = 1;
> -		x = olpc_ec_cmd(0x26, (unsigned char *)&x, 1, NULL, 0);
> +		x = olpc_ec_cmd(EC_DCON_POWER_MODE, (u8 *)&x, 1, NULL, 0);
                                                    ^^^^^^^^
You didn't introduce this but using "x" as the inbuf here messy.
It should be char instead of an int.  The code won't work on big
endian systems.  I know this hardware is only available on little
endian systems and that's why it's not a bug.  It's just an ugly
thing to do.

(Since you didn't introduce this, it means your patch is fine and
you can ignore this email.  I am just commenting in case anyone
wants to fix clean it up).

>  		if (x) {
>  			pr_warn("unable to force dcon to power up: %d!\n", x);
>  			return x;

regards,
dan carpenter
_______________________________________________
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxx
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel




[Index of Archives]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux