On Fri, Nov 30, 2012 at 11:57 AM, Laurent Navet <laurent.navet@xxxxxxxxx> wrote: > fix those checkpatch issues > drivers/staging/line6/pcm.c:84: > WARNING: simple_strtoul is obsolete, use kstrtoul instead > call to obsolete simple_strtoul() replaced by kstrtoint() > > drivers/staging/line6/pcm.c:423: > ERROR: switch and case should be at the same indent > realigns comments > > Signed-off-by: Laurent Navet <laurent.navet@xxxxxxxxx> > --- > drivers/staging/line6/pcm.c | 30 ++++++++++++++++++------------ > 1 file changed, 18 insertions(+), 12 deletions(-) Changes are fine. In the future, please split changes into individual patches. For example: Patch 1 - Rename 'rv' to 'ret' Patch 2 - Replace decprecated simple_strtoul() with kstrtoint() in pcm_set_impulse_period() Patch 3 - Realign comment in line6_init_pcm() switch statement Keeping patches focussed on doing just one thing makes it easier to revert, bisect, and review them. Reviewed-by: Stefan Hajnoczi <stefanha@xxxxxxxxx> _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/devel