> + u32 version_id; /* Version ID of this image format. */ > + u32 package_id; /* Package ID of code release. */ > + u32 build_date; /* Date/time stamp when file was built. */ > + u32 commands_offset; /* Offset to attached commands in Pseudo Hdr format. */ > + u32 loader_offset; /* Offset to bootloader code. */ > + u32 loader_code_address; /* Start address of bootloader. */ > + u32 loader_code_end; /* Where bootloader code ends. */ Just a thought, but if all you are doing is repeating the variable name in the comments, why not just omit the comments? This seems like it documents itself. > + u32 nDspImages; /* Number of DSP images in file. */ What's with the one random prefixed camel-case variable? You could make this consistent with the other naming style (not to mention style conventions). -s _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/devel