Re: [PATCH] Staging: bcm: IPv6Protocol: fixed mutiple coding style issues Fixed several coding style issues to remove most of checkpatch.pl errors and reduce the ammount of warnings.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Sun, Apr 01, 2012 at 06:11:12PM +0100, Max Tottenham wrote:
> Signed-off-by: Max Tottenham <mtottenh@xxxxxxxxx>
> ---
>  drivers/staging/bcm/IPv6Protocol.c |  422 ++++++++++++++++++++----------------
>  1 files changed, 231 insertions(+), 191 deletions(-)
> 
> diff --git a/drivers/staging/bcm/IPv6Protocol.c b/drivers/staging/bcm/IPv6Protocol.c
> index 5b4fd37..6b7baf5 100644
> --- a/drivers/staging/bcm/IPv6Protocol.c
> +++ b/drivers/staging/bcm/IPv6Protocol.c
> @@ -1,51 +1,52 @@
>  #include "headers.h"

Hi Max,

Thanks for taking the time to submit this patch, however, there are a few minor things that need to be resolved before it can be applied by Greg.

First, please break this patch into small increments for better readability. It is easier to review several small patches instead of one big patch.  For example, you can fix all white space and brace“{“ issues in one patch, and in another patch, format pointer variables appropriately, i.e., “Foo *bar”. 

Second, after I applied this patch there appears to be two errors checkpatch.pl identifies.  They are:
ERROR: need consistent spacing around '*' (ctx:WxV)

#3: FILE: staging/bcm/IPv6Protocol.c:3:

+static BOOLEAN MatchSrcIpv6Address(S_CLASSIFIER_RULE *pstClassifierRule,

                                                      ^

ERROR: need consistent spacing around '*' (ctx:WxV)

#4: FILE: staging/bcm/IPv6Protocol.c:4:

+					IPV6Header *pstIpv6Header);

 					           ^

Third, this one is very trivial, but please format all comments like this “/* Comments */ instead of /*Comments*/.  Notice the difference in spacing?

Fourth, I noticed several places where there are conditions defined in this way, “if (0 == uiCountIPSrcAddresses)
”.  I know this is not your doing, but could you change this so it is formatted like so, “if (uiCountIPSrcAddresses == 0)
”. This will make it easier to read.

Please resubmit this patch based on these comments. Thanks a lot!

-Kevin
_______________________________________________
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxx
http://driverdev.linuxdriverproject.org/mailman/listinfo/devel



[Index of Archives]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux