On Tue, 2011-11-01 at 23:22 +0300, Dan Carpenter wrote: > You're right that this driver needs a lot of work. [] > I'd prefer a series of patches: Thanks Dan, that's a good summary of useful changes and their best order. Couple of comments: > [patch 1/3] Staging: bcm: fix whitespace in led_control.c > This would address tabs vs spaces, extra prohibited spaces, and > spaces required around certain chars. Also it would add blank lines > between functions and between declarations and code. And verify with git diff -w and object diffs. > [patch 2/3] Staging: bcm: fix C99 comments in led_control.c > This would fix the 74 ERROR: do not use C99 // comments > > [patch 3/3] Staging: bcm: fix braces style in led_control.c > This would fix the 70 ERROR: that open brace { should be on the > previous line. I'd combine this whitespace change with 1/x myself. > [patch 1/y] Staging: bcm: Rename "Status" to "ret" in led_control.c > [patch 2/y] Staging: bcm: Rename CamelCase variables in led_control.c Dan's rename_review script can help verify this as well. https://lkml.org/lkml/2011/7/19/196 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/devel