On Sun, Oct 30, 2011 at 09:37:04PM -0300, dfm wrote: > 2011/10/30 Joe Perches <joe@xxxxxxxxxxx>: > > Because of the silly name lengths and to avoid excessive > > dereferences, it's better to use a temporary. > > > > typeof(Adapter->PackInfo[uiSearchRuleIndex].stMibsExtServiceFlowTable) *t = > > &Adapter->PackInfo[uiSearchRuleIndex].stMibsExtServiceFlowTable; > > > > t->wmanIfSfid = psfLocalSet->u32SFID; > > > > etc... > > Should I make a another version of the patch or include the change in > a third one? > Probably a resend would be good. It's really nasty to break up variables in the middle. xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx-> yyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy. zzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzzz[1] Obviously don't use typeof() in your code, look up the right type. For the other long lines, I would almost prefer to leave them as is until we find a proper solution (renaming everything in the driver and breaking things up into functions). Split the patch into 2, one that does white space changes and one that does Joe's idea. regards, dan carpenter
Attachment:
signature.asc
Description: Digital signature
_______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/devel