You're not asking the right questions. On Fri, Feb 19, 2021 at 03:28:35PM +0530, Selvakumar Elangovan wrote: > This patch renames CamelCase macros uVar and uModulo into u_var and > u_module in device.h > Is "u_var" a good name? What does the "u_" even mean? > This issue was reported by checkpatch.pl > > Signed-off-by: Selvakumar Elangovan <selvakumar16197@xxxxxxxxx> > --- > drivers/staging/vt6656/device.h | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/drivers/staging/vt6656/device.h b/drivers/staging/vt6656/device.h > index 947530fefe94..6615d356f74a 100644 > --- a/drivers/staging/vt6656/device.h > +++ b/drivers/staging/vt6656/device.h > @@ -385,11 +385,11 @@ struct vnt_private { > struct ieee80211_low_level_stats low_stats; > }; > > -#define ADD_ONE_WITH_WRAP_AROUND(uVar, uModulo) { \ > - if ((uVar) >= ((uModulo) - 1)) \ > - (uVar) = 0; \ > +#define ADD_ONE_WITH_WRAP_AROUND(u_var, u_modulo) { \ > + if ((u_var) >= ((u_modulo) - 1)) \ The \ is not aligned any more. > + (u_var) = 0; \ > else \ > - (uVar)++; \ > + (u_var)++; \ > } This macro is rubbish. How does the wrap around even make sense? I hope that if you review the code a bit I think you will find that the wrap around is impossible? Just fix the two callers and delete this macro. regards, dan carpenter _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel