On Wed, Apr 01, 2020 at 10:54:17PM -0700, Joe Perches wrote: > On Wed, 2020-04-01 at 22:36 -0700, John B. Wyatt IV wrote: > > Fix 4 over 80 char warnings by caching long enum values into local > > variables. > > > > All enums are only used once inside each function (and once inside > > the entire file). > > > > Reported by checkpatch. > > > > Signed-off-by: John B. Wyatt IV <jbwyatt4@xxxxxxxxx> > > --- > > drivers/staging/gasket/apex_driver.c | 13 +++++++++---- > > 1 file changed, 9 insertions(+), 4 deletions(-) > > > > diff --git a/drivers/staging/gasket/apex_driver.c b/drivers/staging/gasket/apex_driver.c > > index 46199c8ca441..f48209ec7d24 100644 > > --- a/drivers/staging/gasket/apex_driver.c > > +++ b/drivers/staging/gasket/apex_driver.c > > @@ -253,6 +253,8 @@ static int apex_get_status(struct gasket_dev *gasket_dev) > > /* Enter GCB reset state. */ > > static int apex_enter_reset(struct gasket_dev *gasket_dev) > > { > > + int idle_gen_reg = APEX_BAR2_REG_IDLEGENERATOR_IDLEGEN_IDLEREGISTER; > > + > > This indirection only makes the code more difficult to understand. I agree, this patch does not improve the readability of the driver at all, which should always be the primary goal of any coding style cleanup. thanks, greg k-h _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel