Hi, On Fri 05 Jul 19, 17:43, Nishka Dasgupta wrote: > On 05/07/19 3:56 PM, Paul Kocialkowski wrote: > > Hi, > > > > On Wed 03 Jul 19, 13:43, Nishka Dasgupta wrote: > > > Remove function cedrus_check_format as all it does is call > > > cedrus_find_format. > > > Rename cedrus_find_format to cedrus_check_format to maintain > > > compatibility with call sites. > > > Issue found with Coccinelle. > > > > Maybe we could have a !! or a bool cast to make coccinelle happy here? > > Coccinelle didn't flag the type mismatch, just the single-line functions. I > could add the bool cast then? Looks like I failed to follow-up on this in due time, sorry. Yes a bool cast would definitely be welcome :) Cheers, Paul > Thanking you, > Nishka > > > Cheers, > > > > Paul > > > > > Signed-off-by: Nishka Dasgupta <nishkadg.linux@xxxxxxxxx> > > > --- > > > drivers/staging/media/sunxi/cedrus/cedrus_video.c | 10 ++-------- > > > 1 file changed, 2 insertions(+), 8 deletions(-) > > > > > > diff --git a/drivers/staging/media/sunxi/cedrus/cedrus_video.c b/drivers/staging/media/sunxi/cedrus/cedrus_video.c > > > index 0ec31b9e0aea..d5cc9ed04fd2 100644 > > > --- a/drivers/staging/media/sunxi/cedrus/cedrus_video.c > > > +++ b/drivers/staging/media/sunxi/cedrus/cedrus_video.c > > > @@ -55,8 +55,8 @@ static inline struct cedrus_ctx *cedrus_file2ctx(struct file *file) > > > return container_of(file->private_data, struct cedrus_ctx, fh); > > > } > > > -static bool cedrus_find_format(u32 pixelformat, u32 directions, > > > - unsigned int capabilities) > > > +static bool cedrus_check_format(u32 pixelformat, u32 directions, > > > + unsigned int capabilities) > > > { > > > struct cedrus_format *fmt; > > > unsigned int i; > > > @@ -76,12 +76,6 @@ static bool cedrus_find_format(u32 pixelformat, u32 directions, > > > return false; > > > } > > > -static bool cedrus_check_format(u32 pixelformat, u32 directions, > > > - unsigned int capabilities) > > > -{ > > > - return cedrus_find_format(pixelformat, directions, capabilities); > > > -} > > > - > > > static void cedrus_prepare_format(struct v4l2_pix_format *pix_fmt) > > > { > > > unsigned int width = pix_fmt->width; > > > -- > > > 2.19.1 > > > > > > -- Paul Kocialkowski, Bootlin Embedded Linux and kernel engineering https://bootlin.com _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel