On Mon, Jul 01, 2019 at 11:49:02AM +0530, Nishka Dasgupta wrote: > Remove function rtl8192_rx_enable as all it does is call > rtl8192_rx_initiate. > Rename rtl8192_rx_initiate to rtl8192_rx_enable and change its type from > static to non-static to maintain compatibility with call sites of > rtl8192_rx_enable. > Issue found with Coccinelle. > > Signed-off-by: Nishka Dasgupta <nishkadg.linux@xxxxxxxxx> > --- > drivers/staging/rtl8192u/r8192U_core.c | 9 ++------- > 1 file changed, 2 insertions(+), 7 deletions(-) > > diff --git a/drivers/staging/rtl8192u/r8192U_core.c b/drivers/staging/rtl8192u/r8192U_core.c > index e78806fef79f..9125c490bb37 100644 > --- a/drivers/staging/rtl8192u/r8192U_core.c > +++ b/drivers/staging/rtl8192u/r8192U_core.c > @@ -713,7 +713,8 @@ static u32 get_rxpacket_shiftbytes_819xusb(struct ieee80211_rx_stats *pstats) > + pstats->RxBufShift); > } > > -static void rtl8192_rx_initiate(struct net_device *dev) > +/* wait to be removed */ I don't think the comment is needed anymore, as you just removed the original function that had this :) thanks, greg k-h _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel