Remove function r8712_free_evt_priv as all it does is call _free_evt_priv. Rename _free_evt_priv to r8712_free_evt_priv to maintain compatibility with call sites. Change type of new r8712_free_evt_priv from static to non-static to match old definition. Signed-off-by: Nishka Dasgupta <nishkadg.linux@xxxxxxxxx> --- drivers/staging/rtl8712/rtl871x_cmd.c | 7 +------ 1 file changed, 1 insertion(+), 6 deletions(-) diff --git a/drivers/staging/rtl8712/rtl871x_cmd.c b/drivers/staging/rtl8712/rtl871x_cmd.c index 269afe8cfd2a..b793edba5505 100644 --- a/drivers/staging/rtl8712/rtl871x_cmd.c +++ b/drivers/staging/rtl8712/rtl871x_cmd.c @@ -87,7 +87,7 @@ int r8712_init_evt_priv(struct evt_priv *pevtpriv) return 0; } -static void _free_evt_priv(struct evt_priv *pevtpriv) +void r8712_free_evt_priv(struct evt_priv *pevtpriv) { kfree(pevtpriv->evt_allocated_buf); } @@ -135,11 +135,6 @@ static struct cmd_obj *_dequeue_cmd(struct __queue *queue) return obj; } -void r8712_free_evt_priv(struct evt_priv *pevtpriv) -{ - _free_evt_priv(pevtpriv); -} - void r8712_enqueue_cmd(struct cmd_priv *pcmdpriv, struct cmd_obj *obj) { if (pcmdpriv->padapter->eeprompriv.bautoload_fail_flag) -- 2.19.1 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel