On Sat, Jun 08, 2019 at 03:27:46PM +0800, Hao Xu wrote: > modify void* to void * for #define inb_p(a) readq((void*)a) > and #define outb_p(d,a) writeq(d,(void*)a) > > Signed-off-by: Hao Xu <haoxu.linuxkernel@xxxxxxxxx> > --- > drivers/staging/kpc2000/kpc2000_i2c.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/staging/kpc2000/kpc2000_i2c.c b/drivers/staging/kpc2000/kpc2000_i2c.c > index a434dd0..de3a0c8 100644 > --- a/drivers/staging/kpc2000/kpc2000_i2c.c > +++ b/drivers/staging/kpc2000/kpc2000_i2c.c > @@ -124,9 +124,9 @@ struct i2c_device { > > // FIXME! > #undef inb_p > -#define inb_p(a) readq((void*)a) > +#define inb_p(a) readq((void *)a) > #undef outb_p > -#define outb_p(d,a) writeq(d,(void*)a) > +#define outb_p(d,a) writeq(d,(void *)a) Alternatively to fixing up the style here, did you consider just removing these two macros altogether and calling [read|write]q directly throughout the kpc_i2c driver (per the '//FIXME' comment)? Unless, I'm misunderstanding something, these macros are shadowing the functions [in|out]b_p, which already exist in io.h. [in|out]b_p are for 8-bit i/o transactions and [read|write]q are for 64-bit transactions, so shadowing the original [in|out]b_p with something that actually does 64-bit transactions is probably potentially misleading here. _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel