On Sun, Feb 27, 2011 at 11:30:10PM +0100, Gábor Stefanik wrote: > >> - lastframe = (fc & IEEE80211_FCTL_MOREFRAGS) == 0; > >> + lastframe = ieee80211_has_morefrags(h->frame_control); > > > > This is reversed. It should be: > > if (ieee80211_has_morefrags(h->frame_control)) > > lastframe = false; > > else > > lastframe = true; > > lastframe = !ieee80211_has_morefrags(h->frame_control); > That way is a bit uglier. The ! and the i sort of blend together and make it harder to read. regards, dan carpenter _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/devel