Re: [PATCH 3/6] Staging: hv: Cleanup hyperv_device variable names

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Feb 25, 2011 at 06:06:32PM -0800, K. Y. Srinivasan wrote:
> Cleanup the names of variables that refer to the
> hyperv_device abstraction.
> 

I have a script I run on rename patches.  For this patch the
command would be:

rename_rev.pl -nc -e 's/device_ctx/device_obj/g' -e 's/\bdev_ctx/dev/g'

It show one variable was missed in storvsc_probe().  

>  	memset(host_device_ctx, 0, sizeof(struct host_device_context));
>  
>  	host_device_ctx->port = host->host_no;
> -	host_device_ctx->device_ctx = device_obj;
> +	host_device_ctx->device_obj = device_obj;
>  
>  	host_device_ctx->request_pool =
>  				kmem_cache_create(dev_name(&device_obj->device),
> @@ -271,7 +271,7 @@ static int storvsc_probe(struct device *device)
>  		return -1;
>  	}
>  
> -	/* host_device_ctx->port = device_info.PortNumber; */
> +	/* host_hyperv_dev->port = device_info.PortNumber; */
>  	host_device_ctx->path = device_info.path_id;
>  	host_device_ctx->target = device_info.target_id;
>  

All the other host_device_ctx variables were renamed to host_device_obj.

regards,
dan carpenter
_______________________________________________
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxx
http://driverdev.linuxdriverproject.org/mailman/listinfo/devel


[Index of Archives]     [Linux Driver Backports]     [DMA Engine]     [Linux GPIO]     [Linux SPI]     [Video for Linux]     [Linux USB Devel]     [Linux Coverity]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]
  Powered by Linux