From: Todd Poynor <toddpoynor@xxxxxxxxxx> Various fixes mainly from the chromium review of the gasket and apex drivers. More to come. Todd Poynor (20): staging: gasket: allow compile for ARM64 in Kconfig staging: gasket: gasket_enable_dev remove unnecessary variable staging: gasket: remove code for no physical device staging: gasket: fix class create bug handling staging: gasket: remove unnecessary code in coherent allocator staging: gasket: don't treat no device reset callback as an error staging: gasket: gasket_mmap return error instead of valid BAR index staging: gasket: apex_clock_gating simplify logic, reduce indentation staging: gasket: gasket page table functions use bool return type staging: gasket: remove else clause after return in if clause staging: gasket: fix comment syntax in apex.h staging: gasket: remove unnecessary parens in page table code staging: gasket: gasket_mmap use PAGE_MASK staging: gasket: remove extra parens in gasket_write_mappable_regions staging: gasket: fix multi-line comment syntax in gasket_core.h staging: gasket: always allow root open for write staging: gasket: top ioctl handler add __user annotations staging: gasket: apex ioctl add __user annotations staging: gasket: common ioctl dispatcher add __user annotations staging: gasket: common ioctls add __user annotations Patches changed from v3 in v4: staging: gasket: remove X86 Kconfig restriction Rename: staging: gasket: allow compile for ARM64 in Kconfig Restore existing "depends on" for X86_64, add ARM64. Only compile for 64-bit architectures known to work with this driver. staging: gasket: always allow root open for write Fold in patch to convert apex_ioctl_check_permissions to return bool Convert gasket_ioctl_check_permissions to use bool types. staging: gasket: apex_ioctl_check_permissions use bool return type Folded into above patch. staging: gasket: annotate ioctl arg with __user Split up into new patches: staging: gasket: top ioctl handler add __user annotations staging: gasket: apex ioctl add __user annotations staging: gasket: common ioctl dispatcher add __user annotations staging: gasket: common ioctls add __user annotations Convert various uses of void * to actual type. Minor formatting and naming changes. Drop Reviewed-By: Dmitry Torokhov due to changes since review. Patches unchanged from v3 in v4: staging: gasket: gasket_enable_dev remove unnecessary variable staging: gasket: remove code for no physical device staging: gasket: fix class create bug handling staging: gasket: remove unnecessary code in coherent allocator staging: gasket: don't treat no device reset callback as an error staging: gasket: gasket_mmap return error instead of valid BAR index staging: gasket: apex_clock_gating simplify logic, reduce indentation staging: gasket: gasket page table functions use bool return type staging: gasket: remove else clause after return in if clause staging: gasket: fix comment syntax in apex.h staging: gasket: remove unnecessary parens in page table code staging: gasket: gasket_mmap use PAGE_MASK staging: gasket: remove extra parens in gasket_write_mappable_regions staging: gasket: fix multi-line comment syntax in gasket_core.h Patches removed from v3 in v4 (already merged to staging-next): staging: gasket: fix typo in apex_enter_reset staging: gasket: fix typo in gasket_core.h comments staging: gasket: whitespace fix in gasket_page_table_init staging: gasket: remove driver registration on class creation failure staging: gasket: hold mutex on gasket driver unregistration staging: gasket: Return EBUSY on mapping create when already in use staging: gasket: Remove stale pointers on error allocating attr array staging: gasket: convert gasket_mmap_has_permissions to bool return staging: gasket: fix gasket_wait_with_reschedule timeout return code staging: gasket: gasket_wait_with_reschedule use msleep staging: gasket: gasket_wait_with_reschedule simplify logic staging: gasket: gasket_wait_with_reschedule use 32 bits of retry staging: gasket: bail out of reset sequence on device callback error staging: gasket: drop gasket_cdev_get_info, use container_of drivers/staging/gasket/Kconfig | 2 +- drivers/staging/gasket/apex.h | 7 +- drivers/staging/gasket/apex_driver.c | 73 +++++------ drivers/staging/gasket/gasket_core.c | 44 +++---- drivers/staging/gasket/gasket_core.h | 10 +- drivers/staging/gasket/gasket_ioctl.c | 144 +++++++++++---------- drivers/staging/gasket/gasket_ioctl.h | 4 +- drivers/staging/gasket/gasket_page_table.c | 64 +++++---- drivers/staging/gasket/gasket_page_table.h | 8 +- 9 files changed, 174 insertions(+), 182 deletions(-) -- 2.18.0.233.g985f88cf7e-goog _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel