On 07/08/18 19:36, Michael Straube wrote:
On 07/08/18 18:46, Joe Perches wrote:
On Sun, 2018-07-08 at 12:38 +0200, Michael Straube wrote:
uint rtw_is_cckratesonly_included(u8 *rate)
{
while (*rate) {
u8 r = *rate & 0x7f;
if (r != 2 && r != 4 && r != 11 && r != 22)
return false;
rate++;
}
return true;
}
The patch has been added to staging-testing already.
I will send patches with your suggestions the next days.
Would it be preferred to declare the variable at the functions beginning,
or doesn't it matter regarding coding style?
uint rtw_is_cckratesonly_included(u8 *rate)
{
u8 r;
while (*rate) {
r = *rate & 0x7f;
...
Best,
Michael
_______________________________________________
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxx
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel