This patch series contains fixes to remove the unused code. It also has patches to reorganize the function and simplify the function logic. Ajay Singh (21): staging: wilc1000: replace crc7_byte() with inline macro CRC7_BYTE staging: wilc1000: align the #define in wilc_spi file staging: wilc1000: remove unnecessary assingment from 'if' conditions staging: wilc1000: remove 'cmd' variable in wilc_spi functions staging: wicl1000: removed the unsed variables in wilc_parse_network_info() staging: wilc1000: remove inner {} in wilc_parse_network_info() staging: wilc1000: simplified if conditions in spi_data_write() staging: wilc1000: remove unused variable scan_while_connected staging: wilc1000: remove unsed typedef wilc_debug_func staging: wilc1000: remove used #define HIF_SDIO_GPIO_IRQ staging: wilc1000: remove unused #define related to MAC status staging: wilc1000: rename mac status macros and moved related #define together staging: wilc1000: rename WILC_WFI_stats to avoid uppercase staging: wilc1000: rename num_reg_frame macro to have uppercase in macro name staging: wilc1000: rename wlan init and deinit function prefixed with wil1000 staging: wilc1000: remove unused elements in 'wilc_priv' struct staging: wilc1000: remove unused enum 'stats_flags' staging: wilc1000: rename P2P_LISTEN_STATE variable to use lowercase staging: wilc1000: remove inner block '{}' in handle_remain_on_chan() staging: wilc1000: change function to static in linux_wlan staging: wilc1000: reorder functions to avoid forward declaration in linux_wlan drivers/staging/wilc1000/coreconfigurator.c | 84 +++++++-------- drivers/staging/wilc1000/host_interface.c | 64 ++++-------- drivers/staging/wilc1000/linux_wlan.c | 122 ++++++++++------------ drivers/staging/wilc1000/wilc_sdio.c | 12 +-- drivers/staging/wilc1000/wilc_spi.c | 70 ++++++------- drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 2 +- drivers/staging/wilc1000/wilc_wfi_netdevice.h | 23 +--- drivers/staging/wilc1000/wilc_wlan.h | 7 -- drivers/staging/wilc1000/wilc_wlan_if.h | 11 +- 9 files changed, 158 insertions(+), 237 deletions(-) -- 2.7.4 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel