Hi, I've missed this patch as I wasn't CCed and just noticed it in staging-next... On Sat, Dec 16, 2017 at 1:43 AM, Kamal Heib <kamalheib1@xxxxxxxxx> wrote: > This patch adds a blank line after declarations to > improve code readability. > > Issue find by checkpatch.pl script. > WARNING: Missing a blank line after declarations > Thank you Kamal for the patch but in this specific case it is checkpatch that is wrong. SHASH_DESC_ON_STACK macro is a definition and should not have a space before it, just like LIST_HEAD macro. The problem is that checkpatch is missing correct handling of crypto API definition macros so it complains. I've sent a patch to fix this awhile back but alas it was not picked up: https://www.mail-archive.com/linux-kernel@xxxxxxxxxxxxxxx/msg1431518.html > Signed-off-by: Kamal Heib <kamalheib1@xxxxxxxxx> > --- > drivers/staging/ccree/ssi_cipher.c | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/drivers/staging/ccree/ssi_cipher.c b/drivers/staging/ccree/ssi_cipher.c > index 791fe75b1d78..270d0a43c516 100644 > --- a/drivers/staging/ccree/ssi_cipher.c > +++ b/drivers/staging/ccree/ssi_cipher.c > @@ -373,6 +373,7 @@ static int cc_cipher_setkey(struct crypto_ablkcipher *atfm, const u8 *key, > /* sha256 for key2 - use sw implementation */ > int key_len = keylen >> 1; > int err; > + > SHASH_DESC_ON_STACK(desc, ctx_p->shash_tfm); > > desc->tfm = ctx_p->shash_tfm; > -- > 2.14.3 Thanks, Gilad -- Gilad Ben-Yossef Chief Coffee Drinker "If you take a class in large-scale robotics, can you end up in a situation where the homework eats your dog?" -- Jean-Baptiste Queru _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel