On Mon, Jul 17, 2017 at 10:53:25PM +0300, Dan Carpenter wrote: > > + if (len + 1 > n) { > > It's more idiomatic to say "if (len >= n)". Plus that's a good habbit My reasoning behind using "((len + 1) > n)" is that len represents the length of the string without null-termination. "buf" is required to store a null-terminator on top of len. Using "len + 1" shows this requirement more clearly; I will add brackets around "len + 1" for emphasis. Thanks for the feedback, I will send a v2. Regards, Jacob von Chorus _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel