Hi, On Wed, Jun 28, 2017 at 4:49 AM, Quytelda Kahja <quytelda@xxxxxxxxxxx> wrote: > Replace the literal function name "visorbus_create_instance" with the format > specifier "%s" so it can be dynamically filled by the __func__ macro. On a general note, I think the actual change or effect is more import to mention in the subject than the fact that you "fix some issue highlighted by checkpatch". Something like Subject: [PATCH] staging: unisys: visorbus: use __func__ instead of function name Of course you can still mention that checkpatch highlighted the issue for you in the description. > > Signed-off-by: Quytelda Kahja <quytelda@xxxxxxxxxxx> > --- > drivers/staging/unisys/visorbus/visorbus_main.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/drivers/staging/unisys/visorbus/visorbus_main.c b/drivers/staging/unisys/visorbus/visorbus_main.c > index 1c785dd19ddd..1c6dc3a3e64a 100644 > --- a/drivers/staging/unisys/visorbus/visorbus_main.c > +++ b/drivers/staging/unisys/visorbus/visorbus_main.c > @@ -1030,7 +1030,7 @@ visorbus_create_instance(struct visor_device *dev) > err_debugfs_dir: > debugfs_remove_recursive(dev->debugfs_dir); > kfree(hdr_info); > - dev_err(&dev->device, "visorbus_create_instance failed: %d\n", err); > + dev_err(&dev->device, "%s failed: %d\n", __func__, err); > return err; > } It looks sane, anyway. Frans _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel