This patch changes the type of variable done from int to boolean. As it is been used as a boolean in the function sfw_test_rpc_done(). It also makes the code more readable and bool data type also requires less memory in comparison to int data type. Signed-off-by: simran singhal <singhalsimran0@xxxxxxxxx> --- drivers/staging/lustre/lnet/selftest/framework.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/lustre/lnet/selftest/framework.c b/drivers/staging/lustre/lnet/selftest/framework.c index ef27bff..3789df6 100644 --- a/drivers/staging/lustre/lnet/selftest/framework.c +++ b/drivers/staging/lustre/lnet/selftest/framework.c @@ -869,7 +869,7 @@ sfw_test_rpc_done(struct srpc_client_rpc *rpc) { struct sfw_test_unit *tsu = rpc->crpc_priv; struct sfw_test_instance *tsi = tsu->tsu_instance; - int done = 0; + bool done = false; tsi->tsi_ops->tso_done_rpc(tsu, rpc); @@ -883,7 +883,7 @@ sfw_test_rpc_done(struct srpc_client_rpc *rpc) /* batch is stopping or loop is done or get error */ if (tsi->tsi_stopping || !tsu->tsu_loop || (rpc->crpc_status && tsi->tsi_stoptsu_onerr)) - done = 1; + done = true; /* dec ref for poster */ srpc_client_rpc_decref(rpc); -- 2.7.4 _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel