Joe Perches wrote:
On Wed, 2010-10-06 at 10:08 -0400, Jason Cooper wrote:
Signed-off-by: Jason Cooper <jason@xxxxxxxxxxxxxx>
diff --git a/drivers/staging/brcm80211/brcmfmac/dhd_linux.c b/drivers/staging/brcm80211/brcmfmac/dhd_linux.c
index 42e2f29..3536011 100644
--- a/drivers/staging/brcm80211/brcmfmac/dhd_linux.c
+++ b/drivers/staging/brcm80211/brcmfmac/dhd_linux.c
@@ -337,9 +337,12 @@ uint dhd_radio_up = 1;
char iface_name[IFNAMSIZ];
module_param_string(iface_name, iface_name, IFNAMSIZ, 0);
-#define DAEMONIZE(a) daemonize(a); \
- allow_signal(SIGKILL); \
- allow_signal(SIGTERM);
+#define DAEMONIZE(a) \
+ do { \
+ daemonize(a); \
+ allow_signal(SIGKILL); \
+ allow_signal(SIGTERM); \
+ } while (0);
You should not have a trailing ";" after a while (0)
Right. My next series will fix this, thanks.
diff --git a/drivers/staging/brcm80211/brcmfmac/wl_iw.c b/drivers/staging/brcm80211/brcmfmac/wl_iw.c
index b2514d1..d9124e2 100644
--- a/drivers/staging/brcm80211/brcmfmac/wl_iw.c
+++ b/drivers/staging/brcm80211/brcmfmac/wl_iw.c
@@ -107,9 +107,12 @@ static wlc_ssid_t g_specific_ssid;
static wlc_ssid_t g_ssid;
-#define DAEMONIZE(a) daemonize(a); \
- allow_signal(SIGKILL); \
- allow_signal(SIGTERM);
+#define DAEMONIZE(a) \
+ do { \
+ daemonize(a); \
+ allow_signal(SIGKILL); \
+ allow_signal(SIGTERM); \
+ } while (0);
Here too, but maybe there should be shared
code for this.
I leave this up to Henry and co, as they've been actively removing unused and duplicate code/includes, etc.
thx,
Jason.
_______________________________________________
devel mailing list
devel@xxxxxxxxxxxxxxxxxxxxxx
http://driverdev.linuxdriverproject.org/mailman/listinfo/devel