On Thu, 2010-09-23 at 20:24 +0000, Haiyang Zhang wrote: > drivers/staging/hv/channel.c | 729 +++++++++++++++++++++--------------------- [] > - struct hv_monitor_page *monitorPage; > + struct hv_monitor_page *monitorpage; Some of these renames would be better with a "_" for the CamelCase conversions (ie: CamelCase -> camel_case). perl regex: 's/\b([A-Z])([a-z]+)([A-Z])([a-z]+)\b/\L$1$2_\L$3$4/g' For instance, I think this should be monitor_page; > -void VmbusChannelGetDebugInfo(struct vmbus_channel *Channel, > - struct vmbus_channel_debug_info *DebugInfo) > +void VmbusChannelGetDebugInfo(struct vmbus_channel *channel, > + struct vmbus_channel_debug_info *debuginfo) perhaps debug_info > { > - struct hv_monitor_page *monitorPage; > - u8 monitorGroup = (u8)Channel->OfferMsg.MonitorId / 32; > - u8 monitorOffset = (u8)Channel->OfferMsg.MonitorId % 32; > + struct hv_monitor_page *monitorpage; > + u8 monitorGroup = (u8)channel->OfferMsg.MonitorId / 32; > + u8 monitorOffset = (u8)channel->OfferMsg.MonitorId % 32; Why not convert these to monitor_(group|offset)? etc... _______________________________________________ devel mailing list devel@xxxxxxxxxxxxxxxxxxxxxx http://driverdev.linuxdriverproject.org/mailman/listinfo/devel