On Tuesday, 18 May 2021 12:17:32 PM AEST Peter Xu wrote: > On Wed, Apr 07, 2021 at 06:42:31PM +1000, Alistair Popple wrote: > > +static inline struct page *pfn_swap_entry_to_page(swp_entry_t entry) > > +{ > > + struct page *p = pfn_to_page(swp_offset(entry)); > > + > > + /* > > + * Any use of migration entries may only occur while the > > + * corresponding page is locked > > + */ > > + BUG_ON(is_migration_entry(entry) && !PageLocked(p)); > > + > > + return p; > > +} > > Would swap_pfn_entry_to_page() be slightly better? > > The thing is it's very easy to read pfn_*() as a function to take a pfn as > parameter... > > Since I'm also recently working on some swap-related new ptes [1], I'm > thinking whether we could name these swap entries as "swap XXX entries". > Say, "swap hwpoison entry", "swap pfn entry" (which is a superset of "swap > migration entry", "swap device exclusive entry", ...). That's where I came > with the above swap_pfn_entry_to_page(), then below will be naturally > is_swap_pfn_entry(). Equally though "hwpoison swap entry", "pfn swap entry", "migration swap entry", etc. also makes sense (at least to me), but does that not fit in as well with your series? I haven't looked too deeply at your series but have been meaning to so thanks for the pointer. > No strong opinion as this is already a v8 series (and sorry to chim in this > late), just to raise this up. No worries, it's good timing as I was about to send a v9 which was just a rebase anyway. I am hoping to try and get this accepted for the next merge window but I will wait before sending v9 to see if anyone else has thoughts on the naming here. I don't have a particularly strong opinion either, and your justification is more thought than I gave to naming these originally so am happy to rename if it's more readable or fits better with your series. Thanks. - Alistair > [1] https://lore.kernel.org/lkml/20210427161317.50682-1-peterx@xxxxxxxxxx/ > > Thanks, > > > + > > +/* > > + * A pfn swap entry is a special type of swap entry that always has a pfn > > stored + * in the swap offset. They are used to represent unaddressable > > device memory + * and to restrict access to a page undergoing migration. > > + */ > > +static inline bool is_pfn_swap_entry(swp_entry_t entry) > > +{ > > + return is_migration_entry(entry) || is_device_private_entry(entry); > > +} > > -- > Peter Xu