Kernel-doc only supports having the comment just before the identifier. The markup for init_completion is actually for __init_completion. Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@xxxxxxxxxx> --- Thats said, IMHO, it would make sense to simply rename __init_completion() to init_completion() and drop this define: #define init_completion(x) __init_completion(x) Signed-off-by: Mauro Carvalho Chehab <mchehab+huawei@xxxxxxxxxx> --- include/linux/completion.h | 10 +++++++++- 1 file changed, 9 insertions(+), 1 deletion(-) diff --git a/include/linux/completion.h b/include/linux/completion.h index bf8e77001f18..ff354918dbf4 100644 --- a/include/linux/completion.h +++ b/include/linux/completion.h @@ -29,6 +29,14 @@ struct completion { }; #define init_completion_map(x, m) __init_completion(x) + +/** + * init_completion - Initialize a dynamically allocated completion + * @x: pointer to completion structure that is to be initialized + * + * This macro will initialize a dynamically created completion + * structure. + */ #define init_completion(x) __init_completion(x) static inline void complete_acquire(struct completion *x) {} static inline void complete_release(struct completion *x) {} @@ -76,7 +84,7 @@ static inline void complete_release(struct completion *x) {} #endif /** - * init_completion - Initialize a dynamically allocated completion + * __init_completion - Initialize a dynamically allocated completion * @x: pointer to completion structure that is to be initialized * * This inline function will initialize a dynamically created completion -- 2.26.2