On Tue, Apr 28, 2020 at 06:38:41PM +0200, Arnaud POULIQUEN wrote: > > > On 4/24/20 10:01 PM, Mathieu Poirier wrote: > > Add a new sync_ops to support use cases where the remoteproc > > core is synchronising with the remote processor. Exactly when to use > > the synchronisation operations is directed by the flags in structure > > rproc_sync_flags. > > > > Signed-off-by: Mathieu Poirier <mathieu.poirier@xxxxxxxxxx> > > --- > > include/linux/remoteproc.h | 24 ++++++++++++++++++++++++ > > 1 file changed, 24 insertions(+) > > > > diff --git a/include/linux/remoteproc.h b/include/linux/remoteproc.h > > index ac4082f12e8b..ceb3b2bba824 100644 > > --- a/include/linux/remoteproc.h > > +++ b/include/linux/remoteproc.h > > @@ -353,6 +353,23 @@ enum rsc_handling_status { > > RSC_IGNORED = 1, > > }; > > > > +/** > > + * struct rproc_sync_flags - platform specific flags indicating which > > + * rproc_ops to use at specific times during > > + * the rproc lifecycle. > > + * @on_init: true if synchronising with the remote processor at > > + * initialisation time > > + * @after_stop: true if synchronising with the remote processor after it was > > + * stopped from the cmmand line > typo command > > + * @after_crash: true if synchronising with the remote processor after > > + * it has crashed > > + */ > > +struct rproc_sync_flags { > > + bool on_init; > > + bool after_stop; > > + bool after_crash; > > +}; > > + > how about a bit field instead (just a proposition)? > Platform driver would set the sync flag and rproc_set_sync_flag could be a > simple mask instead of a switch case. I opted for a structure over bit fields because I thought it would be easier to read/understand. Both approaches are valid and I have to particular preference other than, in my own view, a structure is easier to understand. I'll wait a little to see what other people think. If nobody objects the next revision will have bit fields. > > Is it possible to split this patch in a different ways because difficult to understand as > rproc_sync_flags seems not used before > [PATCH v3 09/14] remoteproc: Deal with synchronisation when crashing Certainly > > Thanks > Arnaud > > > /** > > * struct rproc_ops - platform-specific device handlers > > * @start: power on the device and boot it > > @@ -459,6 +476,9 @@ struct rproc_dump_segment { > > * @firmware: name of firmware file to be loaded > > * @priv: private data which belongs to the platform-specific rproc module > > * @ops: platform-specific start/stop rproc handlers > > + * @sync_ops: platform-specific start/stop rproc handlers when > > + * synchronising with a remote processor. > > + * @sync_flags: Determine the rproc_ops to choose in specific states. > > * @dev: virtual device for refcounting and common remoteproc behavior > > * @power: refcount of users who need this rproc powered up > > * @state: state of the device > > @@ -482,6 +502,7 @@ struct rproc_dump_segment { > > * @table_sz: size of @cached_table > > * @has_iommu: flag to indicate if remote processor is behind an MMU > > * @auto_boot: flag to indicate if remote processor should be auto-started > > + * @sync_with_rproc: true if currently synchronising with the rproc > > * @dump_segments: list of segments in the firmware > > * @nb_vdev: number of vdev currently handled by rproc > > */ > > @@ -492,6 +513,8 @@ struct rproc { > > const char *firmware; > > void *priv; > > struct rproc_ops *ops; > > + struct rproc_ops *sync_ops; > > + struct rproc_sync_flags sync_flags; > > struct device dev; > > atomic_t power; > > unsigned int state; > > @@ -515,6 +538,7 @@ struct rproc { > > size_t table_sz; > > bool has_iommu; > > bool auto_boot; > > + bool sync_with_rproc; > > struct list_head dump_segments; > > int nb_vdev; > > u8 elf_class; > >