* Moger, Babu <Babu.Moger@xxxxxxx> wrote: > New generation of AMD processors start supporting RDT(or QOS) > features. Together these features will be called as RESCTRL. > With more than one vendors supporting these features, it seems > more appropriate to rename these files. > > Create a new directory with the name 'resctrl' and move all the > intel_rdt files to the new directory. This way all the resctrl > related code resides inside one directory. > > Suggested-by: Borislav Petkov <bp@xxxxxxx> > Signed-off-by: Babu Moger <babu.moger@xxxxxxx> > --- > .../x86/include/asm/{intel_rdt_sched.h => resctrl_sched.h} | 0 > arch/x86/kernel/cpu/Makefile | 5 +---- > arch/x86/kernel/cpu/resctrl/Makefile | 7 +++++++ > arch/x86/kernel/cpu/{intel_rdt.c => resctrl/core.c} | 4 ++-- > .../cpu/{intel_rdt_ctrlmondata.c => resctrl/ctrlmondata.c} | 2 +- > arch/x86/kernel/cpu/{intel_rdt.h => resctrl/internal.h} | 6 +++--- > .../kernel/cpu/{intel_rdt_monitor.c => resctrl/monitor.c} | 2 +- > .../cpu/{intel_rdt_pseudo_lock.c => resctrl/pseudo_lock.c} | 6 +++--- > .../pseudo_lock_event.h} | 2 +- > .../cpu/{intel_rdt_rdtgroup.c => resctrl/rdtgroup.c} | 4 ++-- > arch/x86/kernel/process_32.c | 2 +- > arch/x86/kernel/process_64.c | 2 +- > 12 files changed, 23 insertions(+), 19 deletions(-) > rename arch/x86/include/asm/{intel_rdt_sched.h => resctrl_sched.h} (100%) > create mode 100644 arch/x86/kernel/cpu/resctrl/Makefile > rename arch/x86/kernel/cpu/{intel_rdt.c => resctrl/core.c} (99%) > rename arch/x86/kernel/cpu/{intel_rdt_ctrlmondata.c => resctrl/ctrlmondata.c} (99%) > rename arch/x86/kernel/cpu/{intel_rdt.h => resctrl/internal.h} (99%) > rename arch/x86/kernel/cpu/{intel_rdt_monitor.c => resctrl/monitor.c} (99%) > rename arch/x86/kernel/cpu/{intel_rdt_pseudo_lock.c => resctrl/pseudo_lock.c} (99%) > rename arch/x86/kernel/cpu/{intel_rdt_pseudo_lock_event.h => resctrl/pseudo_lock_event.h} (95%) > rename arch/x86/kernel/cpu/{intel_rdt_rdtgroup.c => resctrl/rdtgroup.c} (99%) Ugh, violent NAK on this unreadable directory naming: 'resctrl' is an ugly double/triple abbreviation that nobody recognizes for what it is to begin with, and even the long form 'resource control' is an overly generic naming - *everything* the kernel does is in essence 'resource control' ... So please find some better name and standardize the namespace around it. A couple of suggestions: - 'Hardware Quality of Service', i.e. HW_QOS, hw_qos - or 'CPU bandwidth control', i.e. CPU_BW, cpu_bw - or 'Hardware Bandwidth Control', i.e. HW_BW, hw_bw etc. Thanks, ngo