Re: [PATCH v7 02/13] arch/x86: Rename the RDT functions and definitions

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Nov 09, 2018 at 08:52:27PM +0000, Moger, Babu wrote:
> As AMD is starting to support RDT(or QOS) features, rename
> the RDT functions and definitions to more generic names.
> 
> Replace intel_rdt to resctrl where applicable.
> 
> Signed-off-by: Babu Moger <babu.moger@xxxxxxx>
> ---
>  arch/x86/include/asm/resctrl_sched.h   | 24 ++++++++++++------------
>  arch/x86/kernel/cpu/resctrl.c          | 26 +++++++++++++-------------
>  arch/x86/kernel/cpu/resctrl.h          |  2 +-
>  arch/x86/kernel/cpu/resctrl_monitor.c  | 11 ++++++-----
>  arch/x86/kernel/cpu/resctrl_rdtgroup.c | 10 +++++-----
>  arch/x86/kernel/process_32.c           |  2 +-
>  arch/x86/kernel/process_64.c           |  2 +-
>  7 files changed, 39 insertions(+), 38 deletions(-)

As with patch 1, pls fix subject prefix.

> @@ -637,10 +637,11 @@ int rdt_get_mon_l3_config(struct rdt_resource *r)
>  	 *
>  	 * For a 35MB LLC and 56 RMIDs, this is ~1.8% of the LLC.
>  	 */
> -	intel_cqm_threshold = boot_cpu_data.x86_cache_size * 1024 / r->num_rmid;
> +	resctrl_cqm_threshold = boot_cpu_data.x86_cache_size * 1024 /
> +				r->num_rmid;

No need to break that line here.

With that addressed and FWIW:

Reviewed-by: Borislav Petkov <bp@xxxxxxx>

-- 
Regards/Gruss,
    Boris.

Good mailing practices for 400: avoid top-posting and trim the reply.



[Index of Archives]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Linux FS]     [Yosemite Forum]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [Linux Resources]

  Powered by Linux