Re: [PATCH 1/3] leds: Replace flags bit shift with BIT() macros

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi David,

On 04/30/2017 11:36 PM, David Lin wrote:
> This is for readability as well as to avoid checkpatch warnings when
> adding new bit flag information in the future.
> 
> Signed-off-by: David Lin <dtwlin@xxxxxxxxxx>
> ---
>  include/linux/leds.h | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/include/linux/leds.h b/include/linux/leds.h
> index 64c56d454f7d..f9d10a9efcbe 100644
> --- a/include/linux/leds.h
> +++ b/include/linux/leds.h
> @@ -43,12 +43,12 @@ struct led_classdev {
>  #define LED_SUSPENDED		(1 << 0)
>  #define LED_UNREGISTERING	(1 << 1)

Could we update also these bits?

>  	/* Upper 16 bits reflect control information */
> -#define LED_CORE_SUSPENDRESUME	(1 << 16)
> -#define LED_SYSFS_DISABLE	(1 << 17)
> -#define LED_DEV_CAP_FLASH	(1 << 18)
> -#define LED_HW_PLUGGABLE	(1 << 19)
> -#define LED_PANIC_INDICATOR	(1 << 20)
> -#define LED_BRIGHT_HW_CHANGED	(1 << 21)
> +#define LED_CORE_SUSPENDRESUME	BIT(16)
> +#define LED_SYSFS_DISABLE	BIT(17)
> +#define LED_DEV_CAP_FLASH	BIT(18)
> +#define LED_HW_PLUGGABLE	BIT(19)
> +#define LED_PANIC_INDICATOR	BIT(20)
> +#define LED_BRIGHT_HW_CHANGED	BIT(21)
>  
>  	/* set_brightness_work / blink_timer flags, atomic, private. */
>  	unsigned long		work_flags;
> 

-- 
Best regards,
Jacek Anaszewski
--
To unsubscribe from this list: send the line "unsubscribe linux-doc" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Linux FS]     [Yosemite Forum]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [Linux Resources]

  Powered by Linux