On Sun, Aug 9, 2015 at 6:29 AM, Ming Lei <ming.lei@xxxxxxxxxxxxx> wrote: > On Tue, Aug 4, 2015 at 6:00 PM, Luis R. Rodriguez > <mcgrof@xxxxxxxxxxxxxxxx> wrote: >> From: David Howells <dhowells@xxxxxxxxxx> >> >> We'll be folding in some more checks on fw_read_file_contents(), >> this will make the success case easier to follow. >> >> Signed-off-by: David Howells <dhowells@xxxxxxxxxx> >> Signed-off-by: Luis R. Rodriguez <mcgrof@xxxxxxxx> >> --- >> drivers/base/firmware_class.c | 16 +++++++--------- >> 1 file changed, 7 insertions(+), 9 deletions(-) >> >> diff --git a/drivers/base/firmware_class.c b/drivers/base/firmware_class.c >> index 9ee334c1b872..736fb952b75b 100644 >> --- a/drivers/base/firmware_class.c >> +++ b/drivers/base/firmware_class.c >> @@ -361,20 +361,18 @@ static int fw_get_filesystem_firmware(struct device *device, >> continue; >> rc = fw_read_file_contents(file, buf); >> fput(file); >> - if (rc) >> + if (rc == 0) { >> + dev_dbg(device, "system data: direct-loading firmware %s\n", >> + buf->fw_id); >> + fw_finish_direct_load(device, buf); >> + goto out; > > 'break' should be enough, and the following 'out' label can be saved too. This is true but I left it as it makes the next patch easier to read and follow. >> + } else >> dev_warn(device, "system data, attempted to load %s, but failed with error %d\n", >> path, rc); >> - else >> - break; >> } >> +out: >> __putname(path); Luis -- To unsubscribe from this list: send the line "unsubscribe linux-doc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html