On Fri, Feb 21, 2025 at 01:17:50PM +0000, David Laight wrote: > The fact that you have to keep adding 1 or 2 is a good indication that > it really isn't a good idea. Having to adjust by 1 when converting between string lengths and buffer sizes is super standard in C since strings are NUL-terminated. There are tons of preexisting examples in the tree. I agree that the + 2 is a bit of an eyesore but its needed in that case because that code wants to tack on a newline in addition to a NUL-terminator. Maybe adding a comment there would help? In any case, MAC_ADDR_STR_LEN is a much more descriptive name for what all the changed code is actually doing compared against 3 * ETH_ALEN - 1.