This series adds support for selecting a netconsole egress interface by specifying the MAC address (in place of the interface name) in the boot/module parameter. Signed-off-by: Uday Shankar <ushankar@xxxxxxxxxxxxxxx> --- Changes in v4: - Incorporate Breno Leitao's patch to add (non-RCU) dev_getbyhwaddr and use it (Jakub Kicinski) - Use MAC_ADDR_STR_LEN in ieee80211_sta_debugfs_add as well (Michal Swiatkowski) - Link to v3: https://lore.kernel.org/r/20250205-netconsole-v3-0-132a31f17199@xxxxxxxxxxxxxxx Changes in v3: - Rename MAC_ADDR_LEN to MAC_ADDR_STR_LEN (Johannes Berg) - Link to v2: https://lore.kernel.org/r/20250204-netconsole-v2-0-5ef5eb5f6056@xxxxxxxxxxxxxxx --- Breno Leitao (1): net: Add non-RCU dev_getbyhwaddr() helper Uday Shankar (2): net, treewide: define and use MAC_ADDR_STR_LEN netconsole: allow selection of egress interface via MAC address Documentation/networking/netconsole.rst | 6 +++- drivers/net/netconsole.c | 2 +- drivers/nvmem/brcm_nvram.c | 2 +- drivers/nvmem/layouts/u-boot-env.c | 2 +- include/linux/if_ether.h | 3 ++ include/linux/netdevice.h | 2 ++ include/linux/netpoll.h | 6 ++++ lib/net_utils.c | 4 +-- net/core/dev.c | 37 ++++++++++++++++++++++-- net/core/netpoll.c | 51 +++++++++++++++++++++++++-------- net/mac80211/debugfs_sta.c | 7 +++-- 11 files changed, 97 insertions(+), 25 deletions(-) --- base-commit: 0784d83df3bfc977c13252a0599be924f0afa68d change-id: 20250204-netconsole-4c610e2f871c Best regards, -- Uday Shankar <ushankar@xxxxxxxxxxxxxxx>