On Tue, Feb 4, 2025 at 2:07 PM David Arcari <darcari@xxxxxxxxxx> wrote: > > > Hi Artem, > > On 2/4/25 7:23 AM, Artem Bityutskiy wrote: > > Hi David, > > > > On Tue, 2025-01-28 at 09:11 -0500, David Arcari wrote: > > > >> +The ``use_acpi_cst`` module parameter (recognized by ``intel_idle`` if the > >> +kernel has been configured with ACPI support) can be set to make the driver > >> +ignore the per cpu idle states in lieu of ACPI idle states. ``use_acpi_cst`` > >> +has no effect if ``no_acpi`` is set). > > > > With this change, there will be three parameters: > > > > * no_acpi > > * use_acpi > > * use_acpi_cst > > > > I would like to make the naming as intuitive as possible. We do not rename the > > first 2, but for the 3rd one, I think "force_acpi" would be a better name. Or > > perhaps "no_native"? > > The problem with force_acpi is it is very similar to force_use_acpi > which is what intel_idle.c uses internally: > > drivers/idle/intel_idle.c:module_param_named(use_acpi, force_use_acpi, > bool, 0444); > > That said, I am not attached to the 'use_acpi_cst' parameter name. IMV this is rather about ignoring the built-in states table altogether, IOW something like "pretend that you don't recognize the processor". But it could be something like "prefer_acpi" as far as I'm concerned.