Dan Williams <dan.j.williams@xxxxxxxxx> writes: > Dan Williams wrote: >> Alistair Popple wrote: >> > Longterm pinning of FS DAX pages should already be disallowed by >> > various pXX_devmap checks. However a future change will cause these >> > checks to be invalid for FS DAX pages so make >> > folio_is_longterm_pinnable() return false for FS DAX pages. >> > >> > Signed-off-by: Alistair Popple <apopple@xxxxxxxxxx> >> > --- >> > include/linux/memremap.h | 11 +++++++++++ >> > include/linux/mm.h | 4 ++++ >> > 2 files changed, 15 insertions(+) >> > >> > diff --git a/include/linux/memremap.h b/include/linux/memremap.h >> > index 14273e6..6a1406a 100644 >> > --- a/include/linux/memremap.h >> > +++ b/include/linux/memremap.h >> > @@ -187,6 +187,17 @@ static inline bool folio_is_device_coherent(const struct folio *folio) >> > return is_device_coherent_page(&folio->page); >> > } >> > >> > +static inline bool is_device_dax_page(const struct page *page) >> > +{ >> > + return is_zone_device_page(page) && >> > + page_dev_pagemap(page)->type == MEMORY_DEVICE_FS_DAX; >> > +} >> > + >> > +static inline bool folio_is_device_dax(const struct folio *folio) >> > +{ >> > + return is_device_dax_page(&folio->page); >> > +} >> > + >> > #ifdef CONFIG_ZONE_DEVICE >> > void zone_device_page_init(struct page *page); >> > void *memremap_pages(struct dev_pagemap *pgmap, int nid); >> > diff --git a/include/linux/mm.h b/include/linux/mm.h >> > index ae6d713..935e493 100644 >> > --- a/include/linux/mm.h >> > +++ b/include/linux/mm.h >> > @@ -1989,6 +1989,10 @@ static inline bool folio_is_longterm_pinnable(struct folio *folio) >> > if (folio_is_device_coherent(folio)) >> > return false; >> > >> > + /* DAX must also always allow eviction. */ >> > + if (folio_is_device_dax(folio)) >> >> Why is this called "folio_is_device_dax()" when the check is for fsdax? >> >> I would expect: >> >> if (folio_is_fsdax(folio)) >> return false; >> >> ...and s/device_dax/fsdax/ for the rest of the helpers. > > Specifically devdax is ok to allow longterm pinning since it is > statically allocated. fsdax is the only ZONE_DEVICE mode where there is > a higher-level allocator that does not support a 3rd party the block its > operations indefinitely with a pin. So this needs to be explicit for > that case. Yeah, that all makes sense. I see what I did - was thinking in terms of is this a zone device page - is_device - and if so what type _(fs)dax. folio_is_fsdax() is much clearer though, thanks!