Hi Babu,
On 7/16/24 11:48 AM, Moger, Babu wrote:
On 7/16/24 12:51, Reinette Chatre wrote:
On 7/16/24 8:13 AM, Moger, Babu wrote:
On 7/12/24 17:05, Reinette Chatre wrote:
On 7/3/24 2:48 PM, Babu Moger wrote:
@@ -491,6 +495,7 @@ struct rdt_hw_resource {
unsigned int mbm_width;
unsigned int mbm_cfg_mask;
bool cdp_enabled;
+ bool abmc_enabled;
};
mbm_cntr_enabled? This is architecture specific code so there is more
flexibility
here, but it may make implementation easier to understand if consistent
naming is used
between fs and arch code.
How about "mbm_cntr_assign_enabled" or "cntr_assign_enabled" ?
My preference is to keep the term "mbm_cntr" to be consistent with the
other variables/struct members to help when reading the code.
"mbm_cntr_assign_enabled" does seem to be getting long though.
Are you planning to use it by assigning it to a local variable with shorter
name?
Yes. We can do that.
ok. It is not clear to me how this will turn out. I'm afraid the length may
start to be cumbersome, but we can see how it turns out.
Reinette