On Fri, Mar 22, 2024 at 06:18:37PM +0100, Marco Pagani wrote: > The current implementation of the fpga bridge assumes that the low-level > module registers a driver for the parent device and uses its owner pointer > to take the module's refcount. This approach is problematic since it can > lead to a null pointer dereference while attempting to get the bridge if > the parent device does not have a driver. > > To address this problem, add a module owner pointer to the fpga_bridge > struct and use it to take the module's refcount. Modify the function for > registering a bridge to take an additional owner module parameter and > rename it to avoid conflicts. Use the old function name for a helper macro > that automatically sets the module that registers the bridge as the owner. > This ensures compatibility with existing low-level control modules and > reduces the chances of registering a bridge without setting the owner. > > Also, update the documentation to keep it consistent with the new interface > for registering an fpga bridge. > > Other changes: opportunistically move put_device() from __fpga_bridge_get() > to fpga_bridge_get() and of_fpga_bridge_get() to improve code clarity since > the bridge device is taken in these functions. > > Fixes: 21aeda950c5f ("fpga: add fpga bridge framework") > Suggested-by: Greg Kroah-Hartman <gregkh@xxxxxxxxxxxxxxxxxxx> > Suggested-by: Xu Yilun <yilun.xu@xxxxxxxxx> > Reviewed-by: Russ Weight <russ.weight@xxxxxxxxx> > Signed-off-by: Marco Pagani <marpagan@xxxxxxxxxx> Acked-by: Xu Yilun <yilun.xu@xxxxxxxxx> Applied to for-next.