Re: [PATCH v5 1/2] x86/resctrl: Rename pseudo_lock_event.h to trace.h

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Haifeng,

On 3/7/2024 11:41 PM, Haifeng Xu wrote:
> Now only pseudo-locking part uses tracepoints to do event tracking, but
> other parts of resctrl may need new tracepoints. It is unnecessary to
> create separate header files and define CREATE_TRACE_POINTS in different
> c files which fragments the resctrl tracing.
> 
> Therefore, give the resctrl tracepoint header file a generic name to
> support its use for tracepoints that are not specific to pseudo-locking.
> 
> No functional change.
> 
> Signed-off-by: Haifeng Xu <haifeng.xu@xxxxxxxxxx>
> Suggested-by: Reinette Chatre <reinette.chatre@xxxxxxxxx>
> ---
>  arch/x86/kernel/cpu/resctrl/pseudo_lock.c                   | 2 +-
>  .../x86/kernel/cpu/resctrl/{pseudo_lock_event.h => trace.h} | 6 +++---
>  2 files changed, 4 insertions(+), 4 deletions(-)
>  rename arch/x86/kernel/cpu/resctrl/{pseudo_lock_event.h => trace.h} (88%)
> 
> diff --git a/arch/x86/kernel/cpu/resctrl/pseudo_lock.c b/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
> index 884b88e25141..492c8e28c4ce 100644
> --- a/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
> +++ b/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
> @@ -31,7 +31,7 @@
>  #include "internal.h"
>  
>  #define CREATE_TRACE_POINTS
> -#include "pseudo_lock_event.h"
> +#include "trace.h"
>  
>  /*
>   * The bits needed to disable hardware prefetching varies based on the
> diff --git a/arch/x86/kernel/cpu/resctrl/pseudo_lock_event.h b/arch/x86/kernel/cpu/resctrl/trace.h
> similarity index 88%
> rename from arch/x86/kernel/cpu/resctrl/pseudo_lock_event.h
> rename to arch/x86/kernel/cpu/resctrl/trace.h
> index 428ebbd4270b..ed5c66b8ab0b 100644
> --- a/arch/x86/kernel/cpu/resctrl/pseudo_lock_event.h
> +++ b/arch/x86/kernel/cpu/resctrl/trace.h
> @@ -2,7 +2,7 @@
>  #undef TRACE_SYSTEM
>  #define TRACE_SYSTEM resctrl
>  
> -#if !defined(_TRACE_PSEUDO_LOCK_H) || defined(TRACE_HEADER_MULTI_READ)
> +#if !defined(_TRACE_RESCTRL_H) || defined(TRACE_HEADER_MULTI_READ)
>  #define _TRACE_PSEUDO_LOCK_H

The above #define should match the new name also.

>  
>  #include <linux/tracepoint.h>
> @@ -35,9 +35,9 @@ TRACE_EVENT(pseudo_lock_l3,
>  	    TP_printk("hits=%llu miss=%llu",
>  		      __entry->l3_hits, __entry->l3_miss));
>  
> -#endif /* _TRACE_PSEUDO_LOCK_H */
> +#endif /* _TRACE_RESCTRL_H */
>  
>  #undef TRACE_INCLUDE_PATH
>  #define TRACE_INCLUDE_PATH .
> -#define TRACE_INCLUDE_FILE pseudo_lock_event
> +#define TRACE_INCLUDE_FILE trace
>  #include <trace/define_trace.h>

The rest looks good.

Thank you.

Reinette




[Index of Archives]     [Kernel Newbies]     [Security]     [Netfilter]     [Bugtraq]     [Linux FS]     [Yosemite Forum]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Samba]     [Video 4 Linux]     [Device Mapper]     [Linux Resources]

  Powered by Linux