On 8/11/23 03:52, Nitesh Shetty wrote:
diff --git a/include/linux/blk_types.h b/include/linux/blk_types.h index 0bad62cca3d0..de0ad7a0d571 100644 +static inline bool op_is_copy(blk_opf_t op) +{ + return ((op & REQ_OP_MASK) == REQ_OP_COPY_SRC || + (op & REQ_OP_MASK) == REQ_OP_COPY_DST); +} +
The above function should be moved into include/linux/blk-mq.h below thedefinition of req_op() such that it can use req_op() instead of open-coding it.
Thanks, Bart.