Hi Tony, On 7/13/2023 9:32 AM, Tony Luck wrote: > Sub-NUMA cluster systems provide monitoring resources at the NUMA > node scope instead of the L3 cache scope. > > Rename the cache_level field in struct rdt_resource to the more > generic "scope" and add symbolic names and a helper function. Can the changelog elaborate how the helper function is intended to be used? When changelog just states "add a helper function" it is unnecessary since that is clear from the code. > > No functional change. > > Signed-off-by: Tony Luck <tony.luck@xxxxxxxxx> > Reviewed-by: Peter Newman <peternewman@xxxxxxxxxx> > --- ... > diff --git a/arch/x86/kernel/cpu/resctrl/core.c b/arch/x86/kernel/cpu/resctrl/core.c > index 030d3b409768..6571514752f3 100644 > --- a/arch/x86/kernel/cpu/resctrl/core.c > +++ b/arch/x86/kernel/cpu/resctrl/core.c > @@ -65,7 +65,7 @@ struct rdt_hw_resource rdt_resources_all[] = { > .r_resctrl = { > .rid = RDT_RESOURCE_L3, > .name = "L3", > - .cache_level = 3, > + .scope = SCOPE_L3_CACHE, > .domains = domain_init(RDT_RESOURCE_L3), > .parse_ctrlval = parse_cbm, > .format_str = "%d=%0*x", > @@ -79,7 +79,7 @@ struct rdt_hw_resource rdt_resources_all[] = { > .r_resctrl = { > .rid = RDT_RESOURCE_L2, > .name = "L2", > - .cache_level = 2, > + .scope = SCOPE_L2_CACHE, > .domains = domain_init(RDT_RESOURCE_L2), > .parse_ctrlval = parse_cbm, > .format_str = "%d=%0*x", > @@ -93,7 +93,7 @@ struct rdt_hw_resource rdt_resources_all[] = { > .r_resctrl = { > .rid = RDT_RESOURCE_MBA, > .name = "MB", > - .cache_level = 3, > + .scope = SCOPE_L3_CACHE, > .domains = domain_init(RDT_RESOURCE_MBA), > .parse_ctrlval = parse_bw, > .format_str = "%d=%*u", > @@ -105,7 +105,7 @@ struct rdt_hw_resource rdt_resources_all[] = { > .r_resctrl = { > .rid = RDT_RESOURCE_SMBA, > .name = "SMBA", > - .cache_level = 3, > + .scope = 3, Should this be SCOPE_L3_CACHE? > .domains = domain_init(RDT_RESOURCE_SMBA), > .parse_ctrlval = parse_bw, > .format_str = "%d=%*u", ... > diff --git a/arch/x86/kernel/cpu/resctrl/pseudo_lock.c b/arch/x86/kernel/cpu/resctrl/pseudo_lock.c > index 458cb7419502..42f124ffb968 100644 > --- a/arch/x86/kernel/cpu/resctrl/pseudo_lock.c > +++ b/arch/x86/kernel/cpu/resctrl/pseudo_lock.c > @@ -297,7 +297,7 @@ static int pseudo_lock_region_init(struct pseudo_lock_region *plr) > plr->size = rdtgroup_cbm_to_size(plr->s->res, plr->d, plr->cbm); > > for (i = 0; i < ci->num_leaves; i++) { > - if (ci->info_list[i].level == plr->s->res->cache_level) { > + if (ci->info_list[i].level == plr->s->res->scope) { > plr->line_size = ci->info_list[i].coherency_line_size; > return 0; > } > diff --git a/arch/x86/kernel/cpu/resctrl/rdtgroup.c b/arch/x86/kernel/cpu/resctrl/rdtgroup.c > index 725344048f85..418658f0a9ad 100644 > --- a/arch/x86/kernel/cpu/resctrl/rdtgroup.c > +++ b/arch/x86/kernel/cpu/resctrl/rdtgroup.c > @@ -1348,7 +1348,7 @@ unsigned int rdtgroup_cbm_to_size(struct rdt_resource *r, > num_b = bitmap_weight(&cbm, r->cache.cbm_len); > ci = get_cpu_cacheinfo(cpumask_any(&d->cpu_mask)); > for (i = 0; i < ci->num_leaves; i++) { > - if (ci->info_list[i].level == r->cache_level) { > + if (ci->info_list[i].level == r->scope) { > size = ci->info_list[i].size / r->cache.cbm_len * num_b; > break; > } The last two hunks are red flags to me. Clearly the "cache_level"->"scope" change is done in preparation for "scope" to be assigned more values than 2 or 3. Yet the code continue to use these values as cache levels, comparing it to cacheinfo->level for which I only expect cache levels 2 or 3 to be valid. The above two hunks thus now have potential for errors when rdt_resource->scope has a value that is not 2 or 3. Even if these functions may not be called if rdt_resource->scope is not 2 or 3, this change makes the code harder to understand and maintain because now it requires users to know in which flows particular functions can be called and/or when code paths with invalid values are "ok". Reinette