Gentle ping, Any comments on this series. Thanks Babu > -----Original Message----- > From: Moger, Babu <Babu.Moger@xxxxxxx> > Sent: Thursday, June 1, 2023 2:01 PM > To: corbet@xxxxxxx; reinette.chatre@xxxxxxxxx; tglx@xxxxxxxxxxxxx; > mingo@xxxxxxxxxx; bp@xxxxxxxxx > Cc: fenghua.yu@xxxxxxxxx; dave.hansen@xxxxxxxxxxxxxxx; x86@xxxxxxxxxx; > hpa@xxxxxxxxx; paulmck@xxxxxxxxxx; akpm@xxxxxxxxxxxxxxxxxxxx; > quic_neeraju@xxxxxxxxxxx; rdunlap@xxxxxxxxxxxxx; > damien.lemoal@xxxxxxxxxxxxxxxxxx; songmuchun@xxxxxxxxxxxxx; > peterz@xxxxxxxxxxxxx; jpoimboe@xxxxxxxxxx; pbonzini@xxxxxxxxxx; Moger, > Babu <Babu.Moger@xxxxxxx>; chang.seok.bae@xxxxxxxxx; > pawan.kumar.gupta@xxxxxxxxxxxxxxx; jmattson@xxxxxxxxxx; > daniel.sneddon@xxxxxxxxxxxxxxx; Das1, Sandipan <Sandipan.Das@xxxxxxx>; > tony.luck@xxxxxxxxx; james.morse@xxxxxxx; linux-doc@xxxxxxxxxxxxxxx; linux- > kernel@xxxxxxxxxxxxxxx; bagasdotme@xxxxxxxxx; eranian@xxxxxxxxxx; > christophe.leroy@xxxxxxxxxx; pawan.kumar.gupta@xxxxxxxxxxxxxxx; > jarkko@xxxxxxxxxx; adrian.hunter@xxxxxxxxx; quic_jiles@xxxxxxxxxxx; > peternewman@xxxxxxxxxx; Moger, Babu <Babu.Moger@xxxxxxx> > Subject: [PATCH v5 0/8] x86/resctrl: Miscellaneous resctrl features > > These series adds support few minor features. > 1. Support assigning multiple tasks to control/mon groups in one command. > 2. Add debug mount option for resctrl interface. > 3. Add RMID and CLOSID in resctrl interface when mounted with debug option. > 4. Moves the default control group creation during the mount instead of during > init. > 5. While doing these above changes, found that rftype flags needed some > cleanup. > They were named inconsistently. Re-arranged them much more cleanly now > and added > few comments. Hope it can help future additions. > > --- > v5: > Changes since v4: > Moved the default group creation during mount instead of kernel init. > Tried to address most of the comments on commit log. Added more context > and details. > Addressed feedback about the patch4. Removed the code changes and only > kept the comments. > I am ok to drop patch4. But I will wait for the comment on that. > There were lots of comments. Hope I did not miss anything. Even if I missed, it > is > not intentional. > > v4: Changes since v3 > Addressed comments from Reinette and others. > Removed newline requirement when adding tasks. > Dropped one of the changes on flags. Kept the flag names mostly same. > Changed the names of closid and rmid to ctrl_hw_id and mon_hw_id > respectively. > James had some concerns about adding these files. Addressed it by making > these > files x86 specific. > Tried to address Reinette's comment on patch 7. But due to current code > design > I could not do it exact way. But changed it little bit to make it easy debug > file additions in the future. > > v3: Changes since v2 > Still waiting for more comments. While waiting, addressed few comments > from Fenghua. > Added few more texts in the documentation about multiple tasks assignment > feature. > Added pid in last_cmd_status when applicable. > Introduced static resctrl_debug to save the debug option. > Few minor text changes. > > v2: Changes since v1 > a. Removed the changes to add the task's threads automatically. It required > book keeping to handle the failures and gets complicated. Removed that > change > for now. > b. Added -o debug option to mount in debug mode(comment from Fenghua) > c. Added debug files rmid and closid. Stephane wanted to rename them more > generic to accommodate ARM. It kind of loses meaning if is renamed > differently. > Kept it same for now. Will change if he feels strong about it. > > v4: > https://lore.kernel.org/lkml/168177435378.1758847.8317743523931859131.stg > it@bmoger-ubuntu/ > v3: > https://lore.kernel.org/lkml/167778850105.1053859.14596357862185564029.st > git@bmoger-ubuntu/ > v2: > https://lore.kernel.org/lkml/167537433143.647488.9641864719195184123.stgit > @bmoger-ubuntu/ > v1: > https://lore.kernel.org/lkml/167278351577.34228.12803395505584557101.stgit > @bmoger-ubuntu/ > > Babu Moger (8): > x86/resctrl: Add multiple tasks to the resctrl group at once > x86/resctrl: Simplify rftype flag definitions > x86/resctrl: Rename rftype flags for consistency > x86/resctrl: Add comments on RFTYPE flags hierarchy > x86/resctrl: Introduce "-o debug" mount option > x86/resctrl: Display CLOSID and RMID for the resctrl groups > x86/resctrl: Move default control group creation during mount > x86/resctrl: Introduce RFTYPE_DEBUG flag > > > Documentation/arch/x86/resctrl.rst | 19 ++- > arch/x86/kernel/cpu/resctrl/internal.h | 66 ++++++-- > arch/x86/kernel/cpu/resctrl/rdtgroup.c | 199 +++++++++++++++++-------- > 3 files changed, 212 insertions(+), 72 deletions(-) > > --