On Friday 26 of July 2013 09:40:15 Stephen Warren wrote: > (CC'ing the new DT binding maintainers and mailing list on this reply, > hence quoting the whole of the DT binding) > > On 07/25/2013 06:29 AM, Laxman Dewangan wrote: > > Palmas series device like TPS65913, TPS80036 supports the backup > > battery for powering the RTC when no other energy source is > > available. > > > > The backup battery is optional, connected to the VBACKUP pin, and can > > be nonrechargeable or rechargeable. The rechargeable battery can be > > charged from the system supply using the backup battery charger. > > > > Add support for enabling charging of this backup battery. Also add > > the DT binding document and the new properties to have this support. > > > > Signed-off-by: Laxman Dewangan <ldewangan@xxxxxxxxxx> > > --- > > > > .../devicetree/bindings/rtc/rtc-palmas.txt | 28 > > ++++++++++++++ drivers/rtc/rtc-palmas.c | > > 39 ++++++++++++++++++++ 2 files changed, 67 insertions(+), 0 > > deletions(-) > > create mode 100644 > > Documentation/devicetree/bindings/rtc/rtc-palmas.txt > > > > diff --git a/Documentation/devicetree/bindings/rtc/rtc-palmas.txt > > b/Documentation/devicetree/bindings/rtc/rtc-palmas.txt new file mode > > 100644 > > index 0000000..e4b6910 > > --- /dev/null > > +++ b/Documentation/devicetree/bindings/rtc/rtc-palmas.txt > > @@ -0,0 +1,28 @@ > > +Palmas RTC controller bindings > > + > > +Required properties: > > +- compatible: > > + - "ti,palams-rtc" for palma series of the RTC controller > > +- interrupt-parent: Parent interrupt device, must be handle of palams > > node. +- interrupts: Interrupt number of RTC submodule on device. > > + > > +Optional properties: > > +- ti,back-bat-chg-enable: The palmas series device like TPS65913 or > > TPS80036 + supports the battery backup for powering the RTC when main > > battery is + removed or in very low power state. This flag will > > enable the backup + battery charging. > > +- ti,back-bat-chg-current: Configure charging current. Device > > supports the + charging current as < 100mA or >100mA. > > Does the HW support just two options; less-than or greater-than 100mA? > If so, a Boolean property here might be better. The code below certainly > implies this. > > Given there's only 1 battery, I think "back-" is redundant in the > property names. Since that shortens the names a bit, I'd suggest > spelling everything out in full, perhaps: > > battery-charge-enable > battery-charge-low-current First of all, are those even properties for the RTC binding? Doesn't this PMIC contain a charger part which handles battery charging and so requires such kind of information? Best regards, Tomasz -- To unsubscribe from this list: send the line "unsubscribe linux-doc" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html