On Fri, 2023-02-03 at 15:48 +0100, Janosch Frank wrote: > On 1/25/23 22:26, Janis Schoetterl-Glausch wrote: > > Remove code duplication with regards to the CHECK_ONLY flag. > > Decrease the number of indents. > > No functional change indented. > > > > Suggested-by: Janosch Frank <frankja@xxxxxxxxxxxxx> > > Signed-off-by: Janis Schoetterl-Glausch <scgl@xxxxxxxxxxxxx> > > --- > > > > > > Cosmetic only, can be dropped. > > > > > > arch/s390/kvm/kvm-s390.c | 43 ++++++++++++++++------------------------ > > 1 file changed, 17 insertions(+), 26 deletions(-) > > > > diff --git a/arch/s390/kvm/kvm-s390.c b/arch/s390/kvm/kvm-s390.c > > index 588cf70dc81e..cfd09cb43ef6 100644 > > --- a/arch/s390/kvm/kvm-s390.c > > +++ b/arch/s390/kvm/kvm-s390.c > > @@ -2794,6 +2794,7 @@ static void *mem_op_alloc_buf(struct kvm_s390_mem_op *mop) > > static int kvm_s390_vm_mem_op_abs(struct kvm *kvm, struct kvm_s390_mem_op *mop) > > { > > void __user *uaddr = (void __user *)mop->buf; > > + enum gacc_mode acc_mode; > > void *tmpbuf = NULL; > > int r, srcu_idx; > > > > @@ -2813,33 +2814,23 @@ static int kvm_s390_vm_mem_op_abs(struct kvm *kvm, struct kvm_s390_mem_op *mop) > > goto out_unlock; > > } > > > > - switch (mop->op) { > > - case KVM_S390_MEMOP_ABSOLUTE_READ: { > > - if (mop->flags & KVM_S390_MEMOP_F_CHECK_ONLY) { > > - r = check_gpa_range(kvm, mop->gaddr, mop->size, GACC_FETCH, mop->key); > > - } else { > > - r = access_guest_abs_with_key(kvm, mop->gaddr, tmpbuf, > > - mop->size, GACC_FETCH, mop->key); > > - if (r == 0) { > > - if (copy_to_user(uaddr, tmpbuf, mop->size)) > > - r = -EFAULT; > > - } > > - } > > - break; > > - } > > - case KVM_S390_MEMOP_ABSOLUTE_WRITE: { > > - if (mop->flags & KVM_S390_MEMOP_F_CHECK_ONLY) { > > - r = check_gpa_range(kvm, mop->gaddr, mop->size, GACC_STORE, mop->key); > > - } else { > > - if (copy_from_user(tmpbuf, uaddr, mop->size)) { > > - r = -EFAULT; > > - break; > > - } > > - r = access_guest_abs_with_key(kvm, mop->gaddr, tmpbuf, > > - mop->size, GACC_STORE, mop->key); > > + acc_mode = mop->op == KVM_S390_MEMOP_ABSOLUTE_READ ? GACC_FETCH : GACC_STORE; > > Would the line be too long if that variable would be initialized where > it's defined? Just fits at 100 columns. Want me to move it? > > > + if (mop->flags & KVM_S390_MEMOP_F_CHECK_ONLY) { > > + r = check_gpa_range(kvm, mop->gaddr, mop->size, acc_mode, mop->key); > > We should early return i.e. goto out_unlock. > > IMHO else if, else patterns should either be switches (testing the same > variable) or kept as short as possible / be avoided. > > > + } else if (acc_mode == GACC_FETCH) { > > + r = access_guest_abs_with_key(kvm, mop->gaddr, tmpbuf, > > + mop->size, GACC_FETCH, mop->key); > > I'd guess it's personal taste whether you use GACC_FETCH or access_mode > but if you don't use it here then we can remove the variable all > together, no? Yeah, I think I did replace it, but then undid it. Probably just because it is a bit more explicit. It's used in check_gpa_range, so no, unless you want to dump the expression directly in there. > > > + if (r) > > + goto out_unlock; > > + if (copy_to_user(uaddr, tmpbuf, mop->size)) > > + r = -EFAULT; > > + } else { > > + if (copy_from_user(tmpbuf, uaddr, mop->size)) { > > + r = -EFAULT; > > + goto out_unlock; > > } > > - break; > > - } > > + r = access_guest_abs_with_key(kvm, mop->gaddr, tmpbuf, > > + mop->size, GACC_STORE, mop->key); > > } > > > > out_unlock: >