Hi Vinod, On Fri, Feb 3, 2023 at 6:27 AM Vinod Koul <vkoul@xxxxxxxxxx> wrote: > On 24-01-23, 19:37, Geert Uytterhoeven wrote: > > Use the new devm_of_phy_optional_get() helper instead of open-coding the > > same operation. > > > > Signed-off-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx> > > --- > > v2: > > - Rebase on top of commit 854617f52ab42418 ("net: ethernet: ti: > > am65-cpsw: Handle -EPROBE_DEFER for Serdes PHY") in net-next > > (next-20230123 and later). > > I was trying to apply this on rc1, so ofcourse this fails for me? How do > we resolve this? > > I can skip this patch, provide a tag for this to be pulled into -net > tree Thanks, that's one option. The other option is to postpone this patch, and apply it after v6.3-rc1. Thanks! > > --- a/drivers/net/ethernet/ti/am65-cpsw-nuss.c > > +++ b/drivers/net/ethernet/ti/am65-cpsw-nuss.c > > @@ -1460,11 +1460,9 @@ static int am65_cpsw_init_serdes_phy(struct device *dev, struct device_node *por > > struct phy *phy; > > int ret; > > > > - phy = devm_of_phy_get(dev, port_np, name); > > - if (PTR_ERR(phy) == -ENODEV) > > - return 0; > > - if (IS_ERR(phy)) > > - return PTR_ERR(phy); > > + phy = devm_of_phy_optional_get(dev, port_np, name); > > + if (IS_ERR_OR_NULL(phy)) > > + return PTR_ERR_OR_ZERO(phy); > > > > /* Serdes PHY exists. Store it. */ > > port->slave.serdes_phy = phy; Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds