On Wed, 30 Nov 2022 19:19:10 +0100 Daniel Bristot de Oliveira <bristot@xxxxxxxxxx> wrote: Hi Daniel, As I was adding this series, I noticed an issue that needs to be fixed. > static int run_osnoise(void) > { > + bool irq_disable = test_bit(OSN_IRQ_DISABLE, &osnoise_options); > struct osnoise_variables *osn_var = this_cpu_osn_var(); > u64 start, sample, last_sample; > u64 last_int_count, int_count; > @@ -1315,11 +1323,18 @@ static int run_osnoise(void) > s64 total, last_total = 0; > struct osnoise_sample s; > unsigned int threshold; > + bool preempt_disable; Let's use a different name for the above variable. > u64 runtime, stop_in; > u64 sum_noise = 0; > int hw_count = 0; > int ret = -1; > > + /* > + * Disabling preemption is only required if IRQs are enabled, > + * and the options is set on. > + */ > + preempt_disable = !irq_disable && test_bit(OSN_PREEMPT_DISABLE, &osnoise_options); > + > /* > * Considers the current thread as the workload. > */ > @@ -1335,6 +1350,15 @@ static int run_osnoise(void) > */ > threshold = tracing_thresh ? : 5000; > > + /* > + * Apply PREEMPT and IRQ disabled options. > + */ > + if (irq_disable) > + local_irq_disable(); > + > + if (preempt_disable) > + preempt_disable(); > + The only reason the above works is because preempt_disable() is a macro. If it was a function, then it would likely fail to build (as you are overriding the name with a bool variable). -- Steve