On 7/7/22 05:52, Barry Song wrote: > static inline void arch_tlbbatch_add_mm(struct arch_tlbflush_unmap_batch *batch, > - struct mm_struct *mm) > + struct mm_struct *mm, > + struct vm_area_struct *vma, > + unsigned long uaddr) > { It's not a huge deal, but could we pass 'vma' _instead_ of 'mm'? The implementations could then just use vma->vm_mm instead of the passed-in mm.