On Tue, Dec 28, 2021 at 09:26:01PM +0800, Zhen Lei wrote: > Use parse_crashkernel_high_low() to bring the parsing of > "crashkernel=X,high" and the parsing of "crashkernel=Y,low" together, they > are strongly dependent, make code logic clear and more readable. > > Suggested-by: Borislav Petkov <bp@xxxxxxxxx> Yeah, doesn't look like something I suggested... > @@ -474,10 +472,9 @@ static void __init reserve_crashkernel(void) > /* crashkernel=XM */ > ret = parse_crashkernel(boot_command_line, total_mem, &crash_size, &crash_base); > if (ret != 0 || crash_size <= 0) { > - /* crashkernel=X,high */ > - ret = parse_crashkernel_high(boot_command_line, total_mem, > - &crash_size, &crash_base); > - if (ret != 0 || crash_size <= 0) > + /* crashkernel=X,high and possible crashkernel=Y,low */ > + ret = parse_crashkernel_high_low(boot_command_line, &crash_size, &low_size); So this calls parse_crashkernel() and when that one fails, it calls this new weird parse high/low helper you added. But then all three end up in the same __parse_crashkernel() worker function which seems to do the actual parsing. What I suggested and what would be real clean is if the arches would simply call a *single* parse_crashkernel() function and when that one returns, *all* crashkernel= options would have been parsed properly, low, high, middle crashkernel, whatever... and the caller would know what crash kernel needs to be allocated. Then each arch can do its memory allocations and checks based on that parsed data and decide to allocate or bail. So it is getting there but it needs more surgery... Thx. -- Regards/Gruss, Boris. https://people.kernel.org/tglx/notes-about-netiquette